Warning: is_dir(): open_basedir restriction in effect. File(/www/wwwroot/uat-elearning.itforvn.com/wp-content/plugins/wpdiscuz/themes/default) is not within the allowed path(s): (/www/wwwroot/itforvn.com/:/tmp/) in /www/wwwroot/itforvn.com/wp-content/plugins/wpdiscuz/forms/wpdFormAttr/Form.php on line 140
Zabbix monitoring network 10:Upgrade Zabbix from 4.4 to 5.0 LTS - ITFORVN

Zabbix monitoring network 10:Upgrade Zabbix from 4.4 to 5.0 LTS

10. Upgrade Zabbix from 4.4 to 5.0 LTS

Bài này, mình xin chia sẻ đến các bạn cách nâng cấp zabbix từ 4.4 lên phiên bản 5.0 LTS.

Đầu tiên, các bạn nên lưu ý rằng, chúng ta phải stop Zabbix server bằng câu lệnh:

[root@zabbix ~]# systemctl stop zabbix-server

Nếu các bạn đang chạy máy ảo thì chúng ta nên sử dụng snapshot (VMware) hoặc checkpoint (Hyper-V) để tiến hành sao lưu.

Tiếp theo, chúng ta cần tìm hiểu các requirement của phiên bản Zabbix 5.0 LTS :

  • Database: MySQL 5.5.62 | MariaDB 10.0.37 | PostgreSQL 9.2.24 | Oracle 11.2
  • PHP: 7.2.0

Các bạn có thể tham khảo thêm tại đây.

    1. Kiểm tra các version hiện tại

Trước khi upgrade lên Zabbix 5.0, ta cần kiểm tra các version hiện tại của các dịch vụ mà ta đang chạy có liên quan đến Zabbix như: database, php, zabbix_get, zabbix_server, zabbix_agentd.

Nếu dịch vụ nào không đáp ứng được các requirement của Zabbix 5.0, ta sẽ tiến hành upgrade version của các dịch vụ đó.

Do server Zabbix của mình đang chạy bằng MariaDB nên ta kiểm tra version bằng lệnh:

[root@localhost ~]# mysql --version
mysql Ver 15.1 Distrib 5.5.65-MariaDB, for Linux (x86_64) using readline 5.1

Các bạn có thể xem lại bài triển khai Zabbix Monitoring Server trên MariaDB tại đây.

Tiếp theo, mình sẽ kiểm tra thêm version hiện tại của PHP.

[root@localhost ~]# php --version
PHP 7.2.31 (cli) (built: May 31 2020 16:18:31) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

Do version hiện tại của PHP đáp ứng requirement của Zabbix 5.0 nên ta sẽ không tiến hành upgrade PHP.

Kiểm tra version hiện tại của zabbix_agent, zabbix_get, zabbix_server:

[root@localhost ~]# zabbix_agentd -V
zabbix_agentd (daemon) (Zabbix) 4.4.10[root@localhost ~]# zabbix_get -V 
[root@localhost ~]# zabbix_get -V
zabbix_get (Zabbix) 4.4.10
[root@localhost ~]# zabbix_server -V
zabbix_server (Zabbix) 4.4.10

Version hiện tại của các dịch vụ zabbix_agentd, zabbix_server và zabbix_get đều là 4.4.10.

    2. Tiến hành nâng cấp

Sau khi kiểm tra, ngoài các dịch vụ của Zabbix, chúng ta chỉ phải upgrade MariaDB do chưa đáp ứng được yêu cầu của Zabbix 5.0.

Trước tiên, ta sẽ install EPEL Repository:

[root@localhost ~]# yum -y install epel-release
[root@localhost ~]# yum -y install http://rpms.remirepo.net/enterprise/remi-release-7.rpm

Tiếp theo, chúng ta sẽ tiến hành upgrade MariaDB.

Sử dụng lệnh vi để tạo file responsitory:

[root@localhost ~]# vi /etc/yum.repos.d/maria10-3.repo

và thêm nội dung cho file responsitory vừa tạo:

[mariadb]
name = MariaDB
baseurl = http://yum.mariadb.org/10.3/centos7-amd64
gpgkey=https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
gpgcheck=1

Sử dụng lệnh yum để upgrade MariaDB:

[root@localhost ~]# yum -y upgrade maria*

Tiến hành kiểm tra phiên bản MariaDB sau khi upgrade:

[root@localhost ~]# mysql --version
mysql Ver 15.1 Distrib 10.3.30-MariaDB, for Linux (x86_64) using readline 5.1

Sau khi hoàn tất upgrade cho MariaDB, ta tiến hành upgrade các service của Zabbix.

Đầu tiên, cài đặt Repo của Zabbix 5.0 LTS:

[root@zabbix ~]# rpm -Uvh https://repo.zabbix.com/zabbix/5.0/rhel/7/x86_64/zabbix-release-5.0-1.el7.noarch.rpm
[root@zabbix ~]# yum clean all

Sử dụng lệnh yum để upgrade các dịch vụ của Zabbix:

[root@zabbix ~]# yum -y upgrade zabbix-server-mysql zabbix-web-mysql zabbix-agent
[root@zabbix ~]# yum -y install centos-release-scl

và sửa “enable=1” trong mục [zabbix-frontend] của file /etc/yum.repos.d/zabbix.rep.

Tiến hành gỡ bỏ front-end cũ:

[root@zabbix ~]# yum remove zabbix-web-*

Và cài đặt front-end mới:

[root@zabbix ~]# yum -y install zabbix-web-mysql-scl zabbix-apache-conf-scl

Cập nhật lại time zone trong file /etc/opt/rh/rh-php72/php-fpm.d/zabbix.conf bằng cách bỏ dấu ~ trước dòng php_value [data.timezone] và chỉnh lại thành Asia/Ho_Chi_Minh:

php_value[date.timezone] = Asia/Ho_Chi_Minh

Khởi động lại các dịch vụ:

[root@zabbix ~]# systemctl enable zabbix-server zabbix-agent httpd rh-php72-php-fpm
[root@zabbix ~]# systemctl start zabbix-server zabbix-agent httpd rh-php72-php-fpm

    3. Kiểm tra kết quả sau khi nâng cấp

Sau đó, chúng ta sử dụng trình duyệt truy cập vào Zabbix và kiểm tra:

Hình 10.1: Giao diện Zabbix sau khi upgrade

Tuy nhiên, một số bạn sau khi đăng nhập xong, logo Zabbix ở góc bên trên và thanh search sẽ biến mất như hình:

Hình 10.2: Lỗi hiển thị sau khi upgrade Zabbix

Với lỗi này, các bạn chỉ việc clear cache của trình duyệt thì khắc phục được.

Các bạn lưu ý, các bước trên chúng ta chỉ làm ở Zabbix Server. Tuy nhiên, về phía các agent, các bạn nên upgrade các agent version khớp với version của Zabbix Server nhé.

Chúc các bạn thành công.

Đánh giá post
Subscribe
Notify of
guest
0 Góp ý
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x